<!DOCTYPE html><html xmlns="http://www.w3.org/1999/xhtml" lang="en-US">
<head>	<meta charset="UTF-8" />
<meta property="fb:pages" content="181150638633907" />
<meta property="fb:article_style" content="nsr">
<!-- Mobile Specific Metas--> <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">

<title>  
 
  Parents Petition Norwegian Government over Uganda Arrests 
 
 
  News Of Rwanda &#8211; Rwanda News</title>

<meta name="description" content="The trusted news network in Kigali, the capital of Rwanda. We report breaking news on Rwanda politics and headlines from Africa in Kinyarwanda and English" />
<meta name="keywords" content="newsofrwanda,africa,rwanda news,rwanda,politiki,amakuru,kigali,news,east africa,rwanda amakuru,rwanda politics"/>
	<meta property="og:title" content="Parents Petition Norwegian Government over Uganda Arrests" />
	<meta property="og:description" content="" />
	<meta property="og:type" content="" />
	<meta property="og:image" content="http://www.newsofrwanda.com/wp-content/uploads/2018/01/Rwandans-Uganda-Mbarara-court-150x150.jpg" />
         <link rel="stylesheet" href="http://www.newsofrwanda.com/wp-content/themes/newspapertimes-single-pro/handheld.css" type="text/css" />
            
           
        
	<link rel="stylesheet" href="http://www.newsofrwanda.com/wp-content/themes/newspapertimes-single-pro/style.css" type="text/css" media="screen"/>
    <link rel="shortcut icon" href="http://www.newsofrwanda.com/wp-content/uploads/2013/12/favicon2.png"/>
    <link rel="shortcut icon" href="http://www.newsofrwanda.com/wp-content/uploads/2013/12/favicon2.png" type="image/x-icon"/>
    <meta name="generator" content="Magazine3 Framework" />
	<!--[if IE]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
	<link rel="alternate" type="application/rss+xml" title="News Of Rwanda &#8211; Rwanda News RSS Feed" href="http://www.newsofrwanda.com/feed/" />
	<link rel="pingback" href="http://www.newsofrwanda.com/xmlrpc.php" />
 
    

 

     <style>#content .post {  border: none !important;} </style>  <style media="screen" type="text/css"> .custom1{border-top:3px solid #bd2222 !important;} .custom1 a{color:#bd2222 !important;} .custom2{border-top:3px solid #118f2b !important;}  .custom2 a{color:#118f2b !important}  .custom3{border-top:3px solid #0e55ad !important;}  .custom3 a{color:#0e55ad !important} .custom4{border-top:3px solid #360000 !important;} .custom4 a{color:#360000 !important} .custom5{border-top:3px solid #0e97f2 !important;} .custom5 a{color:#0e97f2 !important} .custom6{border-top:3px solid #680f94 !important;} .custom6 a{color:#680f94 !important} .custom7{border-top:3px solid #000 !important;} .custom7 a{color:#000 !important}    
.custom8{border-top:3px solid #000 !important;} .custom8 a{color:#000 !important} .custom9{border-top:3px solid #000 !important;} .custom9 a{color:#000 !important} .custom10{border-top:3px solid #24a31d !important;} .custom10 a{color:#24a31d !important} .custom11{border-top:3px solid #821d1d !important;} .custom11 a{color:#821d1d !important} .custom12{border-top:3px solid #8c2121 !important;} .custom12 a{color:#8c2121 !important}     </style>
 <link rel="canonical" href="http://www.newsofrwanda.com/uncategorized/32709/parents-petition-norwegian-government-over-uganda-arrests/" /> 


           
     <style type='text/css'>Default CSS Comment</style><link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="News Of Rwanda - Rwanda News &raquo; Parents Petition Norwegian Government over Uganda Arrests Comments Feed" href="http://www.newsofrwanda.com/uncategorized/32709/parents-petition-norwegian-government-over-uganda-arrests/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.newsofrwanda.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='srp-layout-stylesheet-css'  href='http://www.newsofrwanda.com/wp-content/plugins/special-recent-posts/css/layout.css?ver=4.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='social-widget-css'  href='http://www.newsofrwanda.com/wp-content/plugins/social-media-widget/social_widget.css?ver=4.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css'  href='http://www.newsofrwanda.com/wp-content/plugins/wordpress-popular-posts/style/wpp.css?ver=3.2.1' type='text/css' media='all' />
<script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js?ver=4.9.2'></script>
<script type='text/javascript' src='http://www.newsofrwanda.com/wp-content/themes/newspapertimes-single-pro/js/slides.min.jquery.js?ver=4.9.2'></script>
<script type='text/javascript' src='http://www.newsofrwanda.com/wp-content/themes/newspapertimes-single-pro/js/ticker.js?ver=4.9.2'></script>
<script type='text/javascript' src='http://www.newsofrwanda.com/wp-content/themes/newspapertimes-single-pro/js/tabticker.js?ver=4.9.2'></script>
<link rel='https://api.w.org/' href='http://www.newsofrwanda.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.newsofrwanda.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.newsofrwanda.com/wp-includes/wlwmanifest.xml" /> 
<link rel="canonical" href="http://www.newsofrwanda.com/uncategorized/32709/parents-petition-norwegian-government-over-uganda-arrests/" />
<link rel='shortlink' href='http://www.newsofrwanda.com/?p=32709' />
<link rel="alternate" type="application/json+oembed" href="http://www.newsofrwanda.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.newsofrwanda.com%2Funcategorized%2F32709%2Fparents-petition-norwegian-government-over-uganda-arrests%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.newsofrwanda.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.newsofrwanda.com%2Funcategorized%2F32709%2Fparents-petition-norwegian-government-over-uganda-arrests%2F&#038;format=xml" />
				<!-- WordPress Popular Posts v3.2.1 -->
				<script type="text/javascript">//<![CDATA[

					// Create XMLHttpRequest object and set variables
					var xhr = ( window.XMLHttpRequest )
					  ? new XMLHttpRequest()
					  : new ActiveXObject( "Microsoft.XMLHTTP" ),
					url = 'http://www.newsofrwanda.com/wp-admin/admin-ajax.php',
					params = 'action=update_views_ajax&token=3296742f51&id=32709';
					// Set request method and target URL
					xhr.open( "POST", url, true );
					// Set request header
					xhr.setRequestHeader( "Content-type", "application/x-www-form-urlencoded" );
					// Hook into onreadystatechange
					xhr.onreadystatechange = function() {
						if ( 4 == xhr.readyState && 200 == xhr.status ) {
							if ( window.console && window.console.log ) {
								window.console.log( xhr.responseText );
							}
						}
					}
					// Send request
					xhr.send( params );

				//]]></script>
				<!-- End WordPress Popular Posts v3.2.1 -->
				<style>
    #colorcontentwrap8 h2,#colorcontentwrap9 h2
	{
		padding:13px 0 13px;
		
	}
</style> 
</head> <body class="post-template-default single single-post postid-32709 single-format-standard"><div class="top1"><a name="top"></a></div> 
   
    
<div id="wrapper"> 
    <div id="header">
    <div id="topheaderbar">
        <div id="topheaderbar-l">
<a href="http://feeds.feedburner.com/newsofrwanda"><img src="http://www.newsofrwanda.com/wp-content/uploads/2014/01/rss_button.png" alt="Subscribe by rss" height="35" width="110"></a>

        <div id="topnavigation">
                  <div id="nav"><div id="menu"><ul></ul></div></div>
          </div>
        </div>
        <div id="topheaderbar-r">Monday 29 January, 2018</div>
        <div class="cb"></div>
    </div>	    
    <div id="header2">


    <div id="logoright-left-cat-wrapper-title">    <div id="logoleft"><a href="http://www.newsofrwanda.com"><img src="http://www.newsofrwanda.com/wp-content/uploads/2014/07/news-of-rwanda.jpg" alt="Rwanda News" /></a></div> </div>   
 
        <div id="logoright">
    <div id="logoright-left">
    <div id="logoright-left-cat">
    <div id="logoright-left-cat-wrapper">
         
   
   


    <div class="cb"></div>
    </div>
    </div>
    </div>
    <div id="logoright-right">

      <div id="logoright-right-search"><form method="get" id="footersearch1" action="http://www.newsofrwanda.com/">
<input type="text" name="s" value=" Search News - Type Keyword & Hit Enter" onblur="if(this.value=='') this.value=' Search News - Type Keyword & Hit Enter';" onfocus="if(this.value==' Search News - Type Keyword & Hit Enter') this.value='';" id="s2" />
			<input type="submit" value=" " id="searchsubmit" />
		   </form></div>
    <div id="logoright-right-trending"><ul>

     
         


     
         


     
         


     
         


     
         


     
         


     
         


     
         


     
         
        </ul></div>
    </div>
    <div class="cb"></div>
    </div>
     
          
    
    
    <div class="cb"></div>
    </div> 
   
    <div id="header3">
    <div id="header3-1">
    <div id="header3-1-left">  

    </div>
    <div id="header3-2">
     
    <div id="menu2"><ul><div class="menu-header"><ul id="menu-new-menu" class="menu"><li id="menu-item-296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-296"><a title="Irembo" href="http://newsofrwanda.com">Home</a></li>
<li id="menu-item-15954" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15954"><a href="http://www.newsofrwanda.com/category/national/">National</a></li>
<li id="menu-item-227" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-227"><a title="Abanyapolitiki" href="http://www.newsofrwanda.com/category/abanyapolitiki/">Politics</a></li>
<li id="menu-item-31780" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31780"><a href="http://www.newsofrwanda.com/category/block3/">Regional</a></li>
<li id="menu-item-15950" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15950"><a href="http://www.newsofrwanda.com/magazines/">Magazines</a></li>
<li id="menu-item-15827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15827"><a href="http://www.newsofrwanda.com/category/oped/">OP&#038;ED</a></li>
</ul></div></ul></div>
                </div>
    <div class="cb"></div>
    </div>
  	</div>
    <div id="section">
 
    

 
  <div id="column-wrap"> <div id="headgal">
 
<div id="main-content"> 

 <div id="content" style="padding-right:0 !important;">  <div id="homepost">	



	

<div id="datemeta">
<div id="datemeta_l"><b>Published On:</b> Mon, Jan 29th, 2018 </div>
<div id="datemeta_r"><a href="http://www.newsofrwanda.com/category/uncategorized/" rel="category tag">Uncategorized</a> | By <b><a href="http://www.newsofrwanda.com/author/mugabo/" title="View all posts by Peter Mugabo">Peter Mugabo </a></b>    </div>
<div class="cb"></div>
</div>




		<div class="post">



			<h1 class="posttitle">  Parents Petition Norwegian Government over Uganda Arrests</h1>
 


              
  
     
			<div class="entry">

 <div id="metabox"><div id="metabox_share">Share This</div>
 <div class="share">
<ul> <li><a href="http://delicious.com/save" onclick="window.open('http://delicious.com/save?v=5&amp;noui&amp;jump=close&amp;url='+encodeURIComponent('http://www.newsofrwanda.com/uncategorized/32709/parents-petition-norwegian-government-over-uganda-arrests/')+'&amp;title='+encodeURIComponent('Parents Petition Norwegian Government over Uganda Arrests'),'delicious', 'toolbar=no,width=550,height=550'); return false;"> 
<img src="http://www.newsofrwanda.com/wp-content/themes/newspapertimes-single-pro/icon/delicious.png" alt="Add to Delicious" border="0" /></a></li>  
<li><a href="javascript:var d=document,f='http://www.facebook.com/share',l=d.location,e=encodeURIComponent,p='.php?src=bm&amp;v=4&amp;i=1245532349&amp;u='+e(l.href)+'&amp;t='+e(d.title);1;try{if (!/^(.*\.)?facebook\.[^.]*$/.test(l.host))throw(0);share_internal_bookmarklet(p)}catch(z) {a=function() {if (!window.open(f+'r'+p,'sharer','toolbar=0,status=0,resizable=1,width=626,height=436'))l.href=f+p};if (/Firefox/.test(navigator.userAgent))setTimeout(a,0);else{a()}}void(0)" onclick="return wait_for_load(this, event, function() { return false });" id="share_bookmark" title="Share on Facebook">
<img src="http://www.newsofrwanda.com/wp-content/themes/newspapertimes-single-pro/icon/facebook.png" border="0" /></a>
 </li>
<li><a href="http://friendfeed.com/?url=http://www.newsofrwanda.com/uncategorized/32709/parents-petition-norwegian-government-over-uganda-arrests/&amp;title=Parents Petition Norwegian Government over Uganda Arrests" target="_blank">
<img src="http://www.newsofrwanda.com/wp-content/themes/newspapertimes-single-pro/icon/friendfeed.png" alt="Share on FriendFeed" border="0" /></a> </li>
<li><a href='javascript:(function(){var a=window,b=document,c=encodeURIComponent,d=a.open("http://www.google.com/bookmarks/mark?op=edit&amp;output=popup&amp;bkmk="+c(b.location)+"&amp;title="+c(b.title),"bkmk_popup","left="+((a.screenX||a.screenLeft)+10)+",top="+((a.screenY||a.screenTop)+10)+",height=420px,width=550px,resizable=1,alwaysRaised=1");a.setTimeout(function(){d.focus()},300)})();'> 
 <img src="http://www.newsofrwanda.com/wp-content/themes/newspapertimes-single-pro/icon/google.png" border="0" /> </a>
   </li>
<li><a href="http://digg.com/submit?phase=2&url=http://www.newsofrwanda.com/uncategorized/32709/parents-petition-norwegian-government-over-uganda-arrests/&title=Parents Petition Norwegian Government over Uganda Arrests"><img src="http://www.newsofrwanda.com/wp-content/themes/newspapertimes-single-pro/icon/digg.png" alt="Digg" /></a></li>
 <li><a href="http://twitter.com/home?status=Parents Petition Norwegian Government over Uganda Arrests -  http://www.newsofrwanda.com/uncategorized/32709/parents-petition-norwegian-government-over-uganda-arrests/ via @NewsOfRwanda #Rwanda"><img src="http://www.newsofrwanda.com/wp-content/themes/newspapertimes-single-pro/icon/twitter.png" alt="" /></a></li>
<li><a href="http://www.reddit.com/submit" onclick="window.location = 'http://www.reddit.com/submit?url=' + encodeURIComponent(window.location); return false"> 
<img src="http://www.newsofrwanda.com/wp-content/themes/newspapertimes-single-pro/icon/reddit.png" alt="submit to reddit" border="0" /> </a>
</li>

<li><a href="javascript:location.href='http://www.myspace.com/Modules/PostTo/Pages/?c='+encodeURIComponent(location.href)+'&amp;t='+encodeURIComponent(document.title)"> 
<img src="http://www.newsofrwanda.com/wp-content/themes/newspapertimes-single-pro/icon/myspace.png" border="0" /> </a>
</li>

<li><a href="http://www.stumbleupon.com/submit?url=http://www.newsofrwanda.com/uncategorized/32709/parents-petition-norwegian-government-over-uganda-arrests/&title=Parents Petition Norwegian Government over Uganda Arrests"><img src="http://www.newsofrwanda.com/wp-content/themes/newspapertimes-single-pro/icon/stumbleupon.png" border="0" /></a></li>

<li><a href="javascript:void(document.location='http://technorati.com/faves?sub=favthis&amp;add='+escape(document.location))"><img src="http://www.newsofrwanda.com/wp-content/themes/newspapertimes-single-pro/icon/technorati.png" border="0" /></a></li>

<li style="margin-left:9px;"><a href="http://www.newsofrwanda.com/feed/"><img src="http://www.newsofrwanda.com/wp-content/themes/newspapertimes-single-pro/images/subscribe_rss.png" border="0" /></a></li>
</ul> </div>
<div class="ptags"><span class="ptags_heading">Tags</span> 
<div style="margin-top:5px;text-align:center;"></div>
</div>
</div>			  <div id="attachment_32710" style="max-width: 510px" class="wp-caption aligncenter"><a href="http://www.newsofrwanda.com/wp-content/uploads/2018/01/Rwandans-Uganda-Mbarara-court.jpg"><img class="wp-image-32710" src="http://www.newsofrwanda.com/wp-content/uploads/2018/01/Rwandans-Uganda-Mbarara-court.jpg" alt="" width="500" height="300" srcset="http://www.newsofrwanda.com/wp-content/uploads/2018/01/Rwandans-Uganda-Mbarara-court.jpg 450w, http://www.newsofrwanda.com/wp-content/uploads/2018/01/Rwandans-Uganda-Mbarara-court-300x180.jpg 300w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">These 43 Rwandans were arrested as they headed to Tanzania. They were headed for rebel training. They are facing charges in a Ugandan court in what seems like a mock trial</p></div>
<p>A group of parents of Rwandan nationals arbitrarily arrested by Uganda intelligence agencies have written to the Norwegian government asking for intervention. The letter addressed to Norwegian Embassy is written by a group of Parents whose sons were arrested in December 2017 as they headed for rebel recruitment. The 43 young men were recruited by a one Rugema Kayumba of who is facilitator of Rwandan dissident group RNC. Rugema is working with the Ugannda Chieftaincy of Military Intelligence – CMI.</p>
<p>Read full letter below:</p>
<p><strong>Norwegian Embassy, Kampala Uganda</strong></p>
<p><strong style="font-style: inherit;">Plot 18B, Akii-Bua Road</strong><br />
<strong style="font-style: inherit;">P.o.Box 22770</strong><br />
<strong style="font-style: inherit;">Kampala, Uganda</strong><br />
<strong style="font-style: inherit;">Email: emb.kampala@mfa.no</strong></p>
<p><strong style="font-style: inherit;">Dear Ambassador,</strong></p>
<p>Greetings and best wishes for 2018. We write this letter on behalf of our three sons who have become victims of terror recruitment that is sponsored by an individual who claims to be a resident of your great country.</p>
<p>Our sons, whose names we prefer not to mention for their safety, were recruited into a terrorist organization by Rugema Kayumba who had befriended them and was often seen around our home in Western Uganda. We came to learn that he was befriending them so that he could take them to join the Rwanda National Congress (RNC), which has been classified as a terror organization due to their activities in Rwanda.</p>
<p>Rugema frequented our neighborhood telling young men that he was going to get them jobs in Iraq as guards. He promised their parents that once they get training for the Iraq job, it would be easier for them to enter Norway as immigrants. He told them that their security skills would guarantee them jobs in Norway. All of them, including our sons, got excited. We too got excited, especially because he said that he too was a beneficiary of a similar scheme that ultimately made him a resident of Norway.<br />
Being desperate, our children heeded these empty lies. Little did we know that Rugema was instead recruiting them for illegal terror/rebel activities . We only learnt later that the training he was referring to was sending our children into the rank and file of Rwanda National Congress (RNC). It was never about the dream of going to Norway that had excited us.</p>
<p>Now our children are in the hands of Uganda Police which intercepted them at Kikagati border as Rugema was taking them to Minembwe in the Democratic Republic of the Congo where we are told the RNC has a rebel camp.</p>
<p>We are worried, Ambassador. Any parent would be worried. We don’t know what to do. We have only thought of engaging you because Rugema would brag about how easy he can change the lives of our children and ours by taking them to Norway.</p>
<p>We don’t know whether the Norway government actually has this program that recruits young men and eventually gives them residence as Rugema promised our kids because we hear he has moved to neighboring towns promising young men the same.</p>
<p>The lives of many young people are at risk and many families will blame the Norwegian government for whatever happens to their children because Norway is being used as the bait to lure young men into terrorism. If this continues some families here will start thinking that the Norwegian government supports terrorism.</p>
<p>For now, please help us get Kayumba Rugema to explain to Uganda Police where he was taking our children so that the police releases them to us.</p>
<p>Sincerely,</p>
<p><strong style="font-style: inherit;">Concerned Parents</strong></p>



			</div>
 	</div>



	
	<center style="font-weight: bold;"></center>		
 
  
      



      



 

<div id="related" class="clearfix">

 


<div id="relatednews"><div id="relatednewsh2">Related News</div>
<div style="float:right;height:19px;margin-right:10px;">
<!-- AddThis Button BEGIN -->
<div class="addthis_toolbox addthis_default_style ">
<a class="addthis_button_facebook_like" fb:like:layout="button_count"></a>
 <a class="addthis_button_google_plusone" g:plusone:size="medium"></a>

<a href="https://twitter.com/share" class="twitter-share-button" data-url="http://www.newsofrwanda.com/uncategorized/32709/parents-petition-norwegian-government-over-uganda-arrests/" data-via="NewsOfRwanda" data-lang="en" data-hashtags="Rwanda" >Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
</div>
<script type="text/javascript" src="http://s7.addthis.com/js/250/addthis_widget.js"></script>
<!-- AddThis Button END -->
</div>
<div class="cb"></div></div>

	
		<div class="related">

 	<div class="relatedpost">
    
                          <a href="http://www.newsofrwanda.com/uncategorized/31895/opposition-politician-sets-new-return-date-and-it-will-shock-you/"><img width="150" height="125" src="http://www.newsofrwanda.com/wp-content/uploads/2016/12/kayibanda_newsofrwanda-150x125.jpg" class="attachment-relatedimg size-relatedimg wp-post-image" alt="" srcset="http://www.newsofrwanda.com/wp-content/uploads/2016/12/kayibanda_newsofrwanda-150x125.jpg 150w, http://www.newsofrwanda.com/wp-content/uploads/2016/12/kayibanda_newsofrwanda-55x45.jpg 55w" sizes="(max-width: 150px) 100vw, 150px" /></a>
              
            
           
            

             
  
				<h3><a href="http://www.newsofrwanda.com/uncategorized/31895/opposition-politician-sets-new-return-date-and-it-will-shock-you/" rel="bookmark" title="Opposition Politician Sets New Return Date and It Will Shock You">Opposition Politician Sets New Return Date and It Will Shock You</a></h3>



				 



			</div>







		</div> 


	



	
		<div class="related">

 	<div class="relatedpost">
    
                          <a href="http://www.newsofrwanda.com/uncategorized/29884/gisagara-gushima-no-kunenga-mu-muhigo-bizahindura-imikorere-yabo/"><img width="150" height="125" src="http://www.newsofrwanda.com/wp-content/uploads/2015/11/m_22-150x125.jpg" class="attachment-relatedimg size-relatedimg wp-post-image" alt="Gisagara: Gushima no kunenga mu muhigo bizahindura imikorere yabo" srcset="http://www.newsofrwanda.com/wp-content/uploads/2015/11/m_22-150x125.jpg 150w, http://www.newsofrwanda.com/wp-content/uploads/2015/11/m_22-55x45.jpg 55w" sizes="(max-width: 150px) 100vw, 150px" /></a>
              
            
           
            

             
  
				<h3><a href="http://www.newsofrwanda.com/uncategorized/29884/gisagara-gushima-no-kunenga-mu-muhigo-bizahindura-imikorere-yabo/" rel="bookmark" title="Gisagara: Gushima no kunenga mu muhigo bizahindura imikorere yabo">Gisagara: Gushima no kunenga mu muhigo bizahindura imikorere yabo</a></h3>



				 



			</div>







		</div> 


	



	
		<div class="related">

 	<div class="relatedpost">
    
                          <a href="http://www.newsofrwanda.com/uncategorized/27255/rusizi-kutamenya-akari-imusozi-ngo-byababeraga-imbogamizi-zo-kugaruka-mu-gihugu-cyabo/"><img width="150" height="125" src="http://www.newsofrwanda.com/wp-content/uploads/2015/04/m_116-150x125.jpg" class="attachment-relatedimg size-relatedimg wp-post-image" alt="Rusizi: Kutamenya akari imusozi ngo byababeraga imbogamizi zo kugaruka mu gihugu cyabo" srcset="http://www.newsofrwanda.com/wp-content/uploads/2015/04/m_116-150x125.jpg 150w, http://www.newsofrwanda.com/wp-content/uploads/2015/04/m_116-55x45.jpg 55w" sizes="(max-width: 150px) 100vw, 150px" /></a>
              
            
           
            

             
  
				<h3><a href="http://www.newsofrwanda.com/uncategorized/27255/rusizi-kutamenya-akari-imusozi-ngo-byababeraga-imbogamizi-zo-kugaruka-mu-gihugu-cyabo/" rel="bookmark" title="Rusizi: Kutamenya akari imusozi ngo byababeraga imbogamizi zo kugaruka mu gihugu cyabo">Rusizi: Kutamenya akari imusozi ngo byababeraga imbogamizi zo kugaruka mu gihugu cyabo</a></h3>



				 



			</div>







		</div> 


	



	
		<div class="related">

 	<div class="relatedpost">
    
               
           <a href="http://www.newsofrwanda.com/uncategorized/26426/former-uk-premier-pursues-investors-to-opt-rwandas-corruption-free-policy/">  <img src="http://www.newsofrwanda.com/wp-content/themes/newspapertimes-single-pro/images/nothumbnail.png" /> </a> 
            
           
            

             
  
				<h3><a href="http://www.newsofrwanda.com/uncategorized/26426/former-uk-premier-pursues-investors-to-opt-rwandas-corruption-free-policy/" rel="bookmark" title="Former UK Premier pursues Investors to opt Rwanda&#8217;s corruption-free policy">Former UK Premier pursues Investors to opt Rwanda&#8217;s corruption-free policy</a></h3>



				 



			</div>







		</div> 


	



	<div class="cb"></div>







</div> 



 	

<div id="comment_wrapper">

		<!-- You can start editing here. --> 
<div class="comments-box"> <a name="comments" id="comments"></a>
      <!-- If comments are open, but there are no comments. -->
         	 
  <div id="respond">     
    <h2 style="margin-top: 8px;">Leave a comment</h2>
    <div class="cancel-comment-reply"> <small>
      <a rel="nofollow" id="cancel-comment-reply-link" href="/uncategorized/32709/parents-petition-norwegian-government-over-uganda-arrests/#respond" style="display:none;">Click here to cancel reply.</a>      </small> </div>
        <form action="http://www.newsofrwanda.com/wp-comments-post.php" method="post" id="commentform">
            <p>     <input class="author" type="text" value="Your Name..." onclick="this.value='';" name="author" id="author" size="22" tabindex="1"/>
        <label for="author"><small>
        (Required)        </small></label>  </p>    <p>
        <input class="email" type="text" value="Your Email..." onclick="this.value='';" name="email" id="email" size="22" tabindex="2"/>
        <label for="email"><small>(Will not be published)
         (Required)        </small></label>
      </p>
      <p>
        <input class="url" type="text" value="Your Website..." onclick="this.value='';" name="url" id="url" size="22" tabindex="3"/>
        <label for="url"><small>(Optional)</small></label>
      </p>
            <p>
        <textarea name="comment" id="comment" tabindex="4"></textarea>
      </p>        <p><small><strong>XHTML:</strong> You can use these html tags: <code>&lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; </code></small></p>
      <p>        <input class="submit" name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />
        <input type='hidden' name='comment_post_ID' value='32709' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
      </p>
      <p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="b9d11fcef7" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="13"/></p>    </form>
      </div>
  </div></div>




</div> </div><div>

 </div>   </div>  
 


     </div>
   <div id="aside">
      
     

			<div id="sidebar">
<div class="section widget_text"><div id="sidebartitlewrapper"><h3><span>Join us in Facebook</span></h3></div><div class="sectioncont">			<div class="textwidget"><iframe src="//www.facebook.com/plugins/likebox.php?href=http%3A%2F%2Fwww.facebook.com%2Fnewsofrwanda&amp;width=292&amp;height=590&amp;colorscheme=light&amp;show_faces=true&amp;border_color&amp;stream=true&amp;header=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:100%; height:590px;" allowTransparency="true"></iframe></div>
		</div></div>
<!-- WordPress Popular Posts Plugin v3.2.1 [W] [monthly] [views] [custom] -->
<div class="section popular-posts">
<div id="sidebartitlewrapper"><h3><span>Popular Posts</span></h3></div><div class="sectioncont">
<ul>
<li><a href="http://www.newsofrwanda.com/featured1/32705/why-ugandan-president-museveni-is-insulting-rwandas-war-dead/" title="Why Ugandan President Museveni is Insulting Rwanda&#8217;s War Dead" target="_self"></a> <a href="http://www.newsofrwanda.com/featured1/32705/why-ugandan-president-museveni-is-insulting-rwandas-war-dead/" title="Why Ugandan President Museveni is Insulting Rwanda&#8217;s War Dead" class="wpp-post-title" target="_self">Why Ugandan President Museveni is Insulting Rwanda&#8217;s War Dead</a> </li>
<li><a href="http://www.newsofrwanda.com/featured2/32688/rwanda-bypasses-uganda-for-its-own-standard-gauge-railway-line/" title="Rwanda Bypasses Uganda for its own Standard Gauge Railway Line" target="_self"></a> <a href="http://www.newsofrwanda.com/featured2/32688/rwanda-bypasses-uganda-for-its-own-standard-gauge-railway-line/" title="Rwanda Bypasses Uganda for its own Standard Gauge Railway Line" class="wpp-post-title" target="_self">Rwanda Bypasses Uganda for its own Standard Gauge Railway Line</a> </li>
<li><a href="http://www.newsofrwanda.com/featured1/32695/tribert-rujugiro-the-story-of-the-rwandan-billionaire/" title="Tribert Rujugiro: The Story of the Rwandan Billionaire" target="_self"></a> <a href="http://www.newsofrwanda.com/featured1/32695/tribert-rujugiro-the-story-of-the-rwandan-billionaire/" title="Tribert Rujugiro: The Story of the Rwandan Billionaire" class="wpp-post-title" target="_self">Tribert Rujugiro: The Story of the Rwandan Billionaire</a> </li>
<li><a href="http://www.newsofrwanda.com/featured2/32692/israel-joins-rwanda-to-demand-france-acts-on-genocide-suspects/" title="Israel Joins Rwanda to Demand France Acts on Genocide Suspects" target="_self"></a> <a href="http://www.newsofrwanda.com/featured2/32692/israel-joins-rwanda-to-demand-france-acts-on-genocide-suspects/" title="Israel Joins Rwanda to Demand France Acts on Genocide Suspects" class="wpp-post-title" target="_self">Israel Joins Rwanda to Demand France Acts on Genocide Suspects</a> </li>
<li><a href="http://www.newsofrwanda.com/abanyapolitiki/32680/uganda-what-is-behind-softpower-anti-rwanda-propaganda/" title="Uganda: What is Behind SoftPower Anti-Rwanda Propaganda?" target="_self"></a> <a href="http://www.newsofrwanda.com/abanyapolitiki/32680/uganda-what-is-behind-softpower-anti-rwanda-propaganda/" title="Uganda: What is Behind SoftPower Anti-Rwanda Propaganda?" class="wpp-post-title" target="_self">Uganda: What is Behind SoftPower Anti-Rwanda Propaganda?</a> </li>

</ul>
</div></div>
<!-- End WordPress Popular Posts Plugin v3.2.1 -->
		<div class="section widget_recent_entries">		<div id="sidebartitlewrapper"><h3><span>Recent News</span></h3></div><div class="sectioncont">		<ul>
											<li>
					<a href="http://www.newsofrwanda.com/uncategorized/32709/parents-petition-norwegian-government-over-uganda-arrests/">Parents Petition Norwegian Government over Uganda Arrests</a>
									</li>
											<li>
					<a href="http://www.newsofrwanda.com/featured1/32705/why-ugandan-president-museveni-is-insulting-rwandas-war-dead/">Why Ugandan President Museveni is Insulting Rwanda&#8217;s War Dead</a>
									</li>
											<li>
					<a href="http://www.newsofrwanda.com/featured2/32701/arinaitwe-uganda-intelligence-source-from-butabika-mental-facility/">Arinaitwe: Uganda Intelligence Source from Butabika Mental Facility</a>
									</li>
											<li>
					<a href="http://www.newsofrwanda.com/featured1/32695/tribert-rujugiro-the-story-of-the-rwandan-billionaire/">Tribert Rujugiro: The Story of the Rwandan Billionaire</a>
									</li>
											<li>
					<a href="http://www.newsofrwanda.com/featured2/32692/israel-joins-rwanda-to-demand-france-acts-on-genocide-suspects/">Israel Joins Rwanda to Demand France Acts on Genocide Suspects</a>
									</li>
											<li>
					<a href="http://www.newsofrwanda.com/featured2/32688/rwanda-bypasses-uganda-for-its-own-standard-gauge-railway-line/">Rwanda Bypasses Uganda for its own Standard Gauge Railway Line</a>
									</li>
											<li>
					<a href="http://www.newsofrwanda.com/abanyapolitiki/32683/rwandan-dissidents-openly-brag-about-support-by-uganda-intelligence/">Rwandan Dissidents Openly Brag About Support by Uganda Intelligence</a>
									</li>
					</ul>
		</div></div><div class="section widget_text"><div id="sidebartitlewrapper"><h3><span>Subscribe via email</span></h3></div><div class="sectioncont">			<div class="textwidget"><form style="border:1px solid #ccc;padding:3px;text-align:center;" action="http://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('http://feedburner.google.com/fb/a/mailverify?uri=NewsOfRwanda', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"><p>Enter your email address:</p><p><input type="text" style="width:140px" name="email"/></p><input type="hidden" value="NewsOfRwanda" name="uri"/><input type="hidden" name="loc" value="en_US"/><input type="submit" value="Subscribe" /></form></div>
		</div></div>			 <div id="minibars">
	<div id="lmb">
			</div> 
<div id="rmb">
			</div> 
<div class="cb"></div>
	</div> 	</div> 


		</div>   


 <style> #sharebox{ float:left; margin-left:20px; background:#DBDBDB; position:fixed; top:145px;left:0; padding:5px 0; -moz-border-radius:5px; border-radius:5px;border:1px solid #CDCDCD} #sharebox:hover{background:#eee;-moz-transition:all 0.3s ease-in-out 0s;-webkit-transition:all 0.3s ease-in-out 0s;transition:all 0.3s ease-in-out 0s} #sharebox .wdt{ text-align:center; clear:left; padding:2px 4px}</style>
<div id="sharebox"> <div class="wdt"><a href="http://www.newsofrwanda.com/uncategorized/32709/parents-petition-norwegian-government-over-uganda-arrests/" class="twitter-share-button" data-count="vertical" data-via="NewsOfRwanda" data-hashtags="Rwanda" >Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></div>
	<div class="wdt"><div id="fb-root"></div><script src="http://connect.facebook.net/en_US/all.js#xfbml=1"></script><fb:like href="http://www.newsofrwanda.com/uncategorized/32709/parents-petition-norwegian-government-over-uganda-arrests/" send="true" layout="box_count" show_faces="false" action="like" font=""></fb:like></div>
	<div class="wdt"> <!-- Place this tag where you want the +1 button to render -->
<g:plusone size="tall"></g:plusone> <script type="text/javascript">   (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script></div> 	<div class="wdt"><script type="text/javascript">(function() {var s = document.createElement('SCRIPT'), s1 = document.getElementsByTagName('SCRIPT')[0];s.type = 'text/javascript';s.async = true;s.src = 'http://widgets.digg.com/buttons.js';s1.parentNode.insertBefore(s, s1);})();</script> 
	<script src="http://digg.com/tools/diggthis.js" type="text/javascript"></script></div>
	<div class="wdt"><script src="http://www.stumbleupon.com/hostedbadge.php?s=5"></script></div> 
<div class="wdt"><a class="addthis_counter"></a></div> </div> </div> 

</div></div></div><div id="footer">
<div id="footer1">     <div id="footerwrapper1"> <div id="fsidebar1"> 
      <a href="http://www.newsofrwanda.com"><img src="http://www.newsofrwanda.com/wp-content/uploads/2014/07/news-of-rwanda.jpg" alt="Rwanda News" /></a>  </div>
    <div id="fsidebar2"> <div style="margin-top:12px;float:left">	 <div class="fsearchbg1"> 
      	<form method="get" id="footersearch1" action="http://www.newsofrwanda.com/">
<input type="text" name="s" value=" Search News - Type Keyword & Hit Enter" onblur="if(this.value=='') this.value=' Search News - Type Keyword & Hit Enter';" onfocus="if(this.value==' Search News - Type Keyword & Hit Enter') this.value='';" id="s2" />
			<input type="submit" value=" " id="searchsubmit" />
		   </form>
       </div></div>  
 <div id="btt">   <a href="#top"> </a>  </div> 	</div>    <div class="cb"></div>  
<center><ul id="fnav">  
<div id="fotnav" class="ddsmoothmenu1"><ul id="menu-footer" class="menu"><li id="menu-item-3119" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3119"><a href="http://newsofrwanda.com/">Home</a></li>
<li id="menu-item-3120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3120"><a href="http://www.newsofrwanda.com/about-us/">About us</a></li>
<li id="menu-item-3121" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3121"><a href="http://www.newsofrwanda.com/contact/">Contact Us</a></li>
<li id="menu-item-3122" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3122"><a href="http://www.newsofrwanda.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-3124" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3124"><a href="http://www.newsofrwanda.com/terms/">Terms</a></li>
<li id="menu-item-3123" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3123"><a href="http://www.newsofrwanda.com/rss-category/">RSS by category</a></li>
<li id="menu-item-16200" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16200"><a href="http://www.newsofrwanda.com/category/irembo/">Irembo</a></li>
<li id="menu-item-16196" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children arrow menu-item-16196"><a href="http://www.newsofrwanda.com/category/abanyapolitiki/">Abanyapolitiki</a>
<ul class="sub-menu">
	<li id="menu-item-16197" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16197"><a href="http://www.newsofrwanda.com/category/ibibazo-n%e2%80%99ibisubizo/">Ibibazo nâ€™ibisubizo</a></li>
	<li id="menu-item-16198" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16198"><a href="http://www.newsofrwanda.com/category/ibikorwa/">Ibikorwa</a></li>
	<li id="menu-item-16199" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16199"><a href="http://www.newsofrwanda.com/category/imitwe-ya-politiki/">Imitwe ya politiki</a></li>
	<li id="menu-item-16202" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16202"><a href="http://www.newsofrwanda.com/category/rwanda-politics-2/">Rwanda Politics</a></li>
	<li id="menu-item-16203" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16203"><a href="http://www.newsofrwanda.com/category/ubuvugizi/">Ubuvugizi</a></li>
</ul>
</li>
</ul></div> 	</ul></center>  
     <div style="clear: both;"> </div>     </div>  </div>
 
<div id="footer2">  <div id="footerwrapper2">
      <div id="fotbot">
      <div class="fotlogoleft"> 
        <div class="fotcopy">
    All Rights Reserved | NewsOfRwanda.com 
        </div>     		  </div>
	   	<div class="fotlogoright">
	      	</div>    	<div class="cb"></div>
   </div>  </div>   	</div></div>





<div id="menu3"><ul>
<div class="menu-header"><ul id="menu-new-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-296"><a title="Irembo" href="http://newsofrwanda.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15954"><a href="http://www.newsofrwanda.com/category/national/">National</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-227"><a title="Abanyapolitiki" href="http://www.newsofrwanda.com/category/abanyapolitiki/">Politics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31780"><a href="http://www.newsofrwanda.com/category/block3/">Regional</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15950"><a href="http://www.newsofrwanda.com/magazines/">Magazines</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15827"><a href="http://www.newsofrwanda.com/category/oped/">OP&#038;ED</a></li>
</ul></div></ul></div> 

<script type='text/javascript' src='http://www.newsofrwanda.com/wp-includes/js/comment-reply.min.js?ver=4.9.2'></script>
<script type='text/javascript' src='http://www.newsofrwanda.com/wp-includes/js/wp-embed.min.js?ver=4.9.2'></script>
<script async="async" type='text/javascript' src='http://www.newsofrwanda.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.1'></script>
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-27819952-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//newsofrwanda.com/analytics/";
    _paq.push(['setTrackerUrl', u+'piwik.php']);
    _paq.push(['setSiteId', 1]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'piwik.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//newsofrwanda.com/analytics/piwik.php?idsite=1" style="border:0;" alt="" /></p></noscript>
<!-- End Piwik Code -->

  </body> </html>